General Feedback

Do you have an idea or suggestion based on your experience with Windows Server? We would love to hear it! Please take a few minutes to submit your idea in the one of the forums available on the right or vote up an idea submitted by another Windows Server customer. All of the feedback you share in these forums is monitored and reviewed by the Microsoft engineering teams responsible for building Windows Server. Suggestions can apply to both released and Technical Preview versions of Windows Server.

Important:

1. Remote Desktop Services (RDS)-related feedback must be provided in their UV site: https://remotedesktop.uservoice.com/forums/266795-remote-desktop-services-for-enterprises

2. Requests for feature changes around the end-user experience, such as desktop shell, start menu, individual consumer apps, etc. must be provided through the Windows 10 Feedback Hub tool. We have no ownership of these types of non-Windows Server components.

3. This forum (General Feedback) is used for any broad feedback related to Windows Server. Feedback for specific areas like Storage, Networking, Virtualization, Nano Server, etc., should be provided in one of the forums available on the right. It is not for bug filings. If you find a bug with Windows Server please open a support case at https://support.microsoft.com and report it – these cases are free.

If you have technical questions or need help with Windows Server, please visit our “TechNet Forums” https://social.technet.microsoft.com/Forums/windowsserver/en-US/home?category=windowsserver

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Add support to multi language server core 2019 when running on containers

    Default servercore:1809 image came with en-US.

    - At this moment, for Server Core 2019, you have to install language pack by yourself: https://docs.microsoft.com/pt-br/windows-server/get-started-19/rel-notes-19.
    - The way to do it, is using lpksetup: https://support.microsoft.com/en-us/help/4466511/cannot-configure-language-pack-for-windows-server-2019
    - But lpksetup.exe crashes when running on container

    I've described step by step how to reproduce lpksetup.exe error on container, **producing crash report logs** that I've extracted from container.
    All here: https://github.com/sanguedemonstro/docker-playground/issues/1#issuecomment-453078549

    With extra details here: https://github.com/sanguedemonstro/docker-playground/blob/master/langpack-on-servercore2019.md#why-am-i-playing-around-this-subject

    But I'm not able to understand logs or fix windows base image. And I can't open support ticket once I'm not MS partner.

    So if anyone could help I'm…

    33 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  2. Is this a Permission-Bug in Windows Firewall Logging?

    #Windows Firewall Log BUG

    Situation:
    New Installed Server With 2016 Standard. Patched and up2date with June-2019 CU.
    Created a new Domain with itself beeing the first domaincontroler. Created a GPO to activate Windows Firewall and enable Logging of DROP and ALLOW to pfirewall-domain.log in the default-path.

    What happens?
    The Log can´t be written, no access denied. Sysinternals Procmon shows no "Access Denied". Shows a few creates but does not write.
    [...]
    Detailed Explanation:
    https://social.technet.microsoft.com/Forums/en-US/b8ba16b4-8b7e-4c3a-a610-a67fed2e87ae/is-this-a-permissionbug-in-windows-firewall-logging?forum=win10itprosecurity

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  3. Resolve the Windows Server 2019 bug stopping it from booting on certain servers with UEFI enabled when the Hyper-V Role is installed.

    There's a pretty big problem on some servers (at least two Dell PET Servers I've tried so far) that stops Server 2019 from booting/goes into a boot loop once the Hyper-V role is installed.

    24 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  4. Fix Windows Server 2019 Active Directory Domain Controller and Environment Bugs

    It would appears I'm not the only one experiencing the issue, I did a fresh install promote it to a Windows Server 2016 Forest and Domain AD. After the reboot I realize the Start Menu settings cannot be changed, next I found that whole load of permission error whenever I try to launch anything that requires Administrator privilege including Server Manager, Settings and Control Panel. After that I went to check the permission settings of the C drive and Windows folder as compared to previous version of Windows Server, "Authenticated Users" is no longer part of the default permissions. This…

    16 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  5. Powershell bug with parameter set and Resolve-DnsName triggered -Debug prompt

    Expect non-interactive execution of script
    Result get debug prompt despite no -Debug flag

    It is so strange you have to see it to understand

    param (
    [Parameter(Mandatory=$True, ParameterSetName='defaults')]
    [ValidateSet('world', 'people')]
    [string]$Thing
    )
    Write-Host "Hello $Thing"

    Resolve-DnsName google.com -Server 8.8.8.8

    Try it:

    .\Test.ps1 -Thing world -Debug
    Hello world
    DEBUG: 196616

    Confirm
    Continue with this operation?
    [Y] Yes [A] Yes to All [H] Halt Command [S] Suspend [?] Help (default is "Y"):

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  6. Fix single update installation triggering multiple updates through sconfig (2016)

    Windows Server 2016 with GUI, Exchange Server 2016 running. When I attempt to install a single update using sconfig (in this case the Servicing Stack Update) the OS "helpfully" installed the pending Security Update for Exchange Server without prompting. The installation of this update stops all Exchange Server services.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  7. Fix .NET-incompatibility with Essentials Dashboard on Server 2016

    With the latest .Net updates the dashboard is not useable anymore: Warnings can't be ignored or deleted, computers can't be removed...
    Only the progressbar appears, cpu usage rises to 100% and dashboard gets stuck or crashes.

    49 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    13 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  8. get-dhcpserverv4reservation command bug

    get-dhcpserverv4reservation command

    when use
    Get-DhcpServerv4Reservation -ScopeId $ScopeId -ComputerName $DHCPServer -ClientId $ClientId
    it returns the leased (not reserved) client IP if the ClientID exists and is active in the given scope
    There is a workaround = collect all reservations for the given scope and search in the result against ClientID

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  9. SeShutdownPrivelege, SeUndockPrivelege, and SeTimeZonePrivelege not added to Administrators Group... only for Built-in Admin

    SeShutdownPrivelege, SeUndockPrivelege, and SeTimeZonePrivelege are not added to Administrators Group... only for Built-in Admin. This makes it so setting the timezone via the timedate.cpl in Server Core impossible if logged in as Domain Admin. This also makes ExitWindowsEx function in MSVC unusable on 2019.

    Previously, these worked on 2016. A workaround is to add the user (or users group) account via the Security Policy for User Rights Assessment in gpedit.msc.

    5 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  10. Server 2012 R2 VM Live Migration to Server 2019, VM won't boot after shutting down

    If you use Hyper V Live Migration from Server 2012 R2 (not sure if any other OS) to migrate to Server 2019. The migration works but as soon as you shut down the VM and try to start it again, will no longer boot. It turns on/off 3 times and remains off.

    I also did cluster to cluster migration in VMM and this is the same behaviour.

    It looks like it is due the migrated MAC address, if I set the VM to get a new dynamic mac address it seems to work. If I set it to it's original…

    11 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  11. Windows Server 2016 Update Needs to be FIXED

    Unacceptable windows server 2016 updates will take 48 hours to complete. My Linux servers will update in 10 minutes of time. This slow update process is akin to taking 48 hours to fill gas tank on your car. FIX IT ALREADY.

    6 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  12. Stabilize RSAT ActiveDirectory PowerShell module (giving transient errors all the time)

    The RSAT ActiveDirectory PowerShell module is regularly throwing transient errors when run by a number of PowerShell sessions in parallel. Many people are having this issue and there's no remedy for it.

    This mainly happens when a number of PowerShell instances are running the same Active Directory PowerShell script in parallel (mainly performed by mass updates scheduled over night, each launching a new, separate PowerShell session for each mass update step).

    When calling Get-ADUser (or similar), the ActiveDirectory module either throws "A connection to the directory on which to process the request was unavailable. This is likely a transient condition."…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  13. robocopy /mt causes incorrect summary for copied and skipped files

    Issue relating to robocopy is detailed here:
    https://social.technet.microsoft.com/Forums/exchange/en-US/cd9b83c1-bd01-41ee-8f56-ea9db4e598bb/robocopy-with-mt-switch-seems-to-show-different-summary-info-why?forum=winserverfiles&prof=required

    When using the /MT to a directory that already exists the files are not skipped. This is the opposite behavior to what happens without the /MT flag. This issue is picked up reviewing the summary.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  14. Server 2016 updates MUCH too slow!

    I've never seen Windows hosts take so long to update as Server 2016 does. Between taking sometimes over an hour to download 15MB updates on an extremely fast connection, to the sometimes HOURS-long process, something is BROKEN! And yet all I see in eventvwr is "Installation started" with null detail as to what's taking so bloody forever.

    FIX THIS MICROSOFT. People have been complaining about this for YEARS.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  15. [Microsoft Remote Desktop for Mac] Display freezes after first frame

    I am connecting to a VirtualBox VM exposed via VRDP. The first frame loads but then it stops. Mouse and Keyboard events are still sent to the VM (I can see things happen in the preview window), but the screen on MS Remote Desktop never updates.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  16. Bug in Android RD 8.1.71.387 using danish keyboard.

    Not sure why I was guided to windows server, the problem is with the Android RD client.
    In a danish environment, the bottom left key is supposed to be - (minus) and the shifted value _ (underscore), This is the key immediately to the left of the right shift key.
    Using the Android RD client on a Acer Chromebook with danish keyboard towards a Windows 10 VDI the keys come out as + (plus) and the shifted value ? (questionmark).
    Connecting to the same VDI with RD from a Windows PC renders the correct keys, and using the chromebook in…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  17. Server 2016 jumping ahead of time

    I have found a wired thing, I got a file server that has shadow copies configured for one of its drives and it seems that server jumps ahead of time at some point and creates shadow copies for future. Not sure if it happens because of a bug. I've fully updated the server and reported the issue here as one of TechNet guy suggested. please reachout for more details. janindu@live.com Thanks

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  18. Offline files

    On Windows 10, Office 2016/2019 can not open offline files from redirected folders when internet connection is not available. If internet connection is available (even public one), there is no problem. Other file types (pdf, jpg) have no issues. The server that stores the redirected folders is not accessible through internet, only on local network. Is there anything I can do to fix this?

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  19. Windows Server 2019 RDS Remote Apps Freeze/Disconnect

    When using LAPS UI or Server Manager which I believe these are .NET applications with RDS Remote Apps the right-click context menus or an admin prompt freeze the RemoteApp session and eventually disconnect. This issue is not present in Server 2016 and I assume this has something to do with the way RemoteApps works in 2019

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  20. Use a proper issue tracker such as available on github.com or gitlab.com

    Use a proper issue tracker such as available on github.com or gitlab.com.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 6
  • Don't see your idea?

Feedback and Knowledge Base