To improve Windows Server I suggest you ...

Disable Hardware Offloads By Default

The vast majority of issues I encounter in the Hyper-V community, are related to hardware offloads such as VMQ and ODX. Microsoft is relying on drivers and firmwares that OEMs are either releasing with incorrect default configurations (VMQ enabled on 1 GbE NICs) or buggy releases (ODX corrupting VHD/X files). And to be honest, I'm thinking of getting business cards printed with "turn off VMQ" and "turn off ODX" on them.

The customers blame Microsoft because "Hyper-V is buggy". It's time to shift the blame on OEMs and to stop giving us the tired line of "we're working with OEMs". Shift the responsibility to the OEMs by disabling hardware offloads by default. That way a customer has to know about the feature, turn it on, and take the responsibility to test it. And if they don't do that, at least they'll have a more stable compute platform.

29 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Aidan FinnAidan Finn shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Alex BucklandAlex Buckland commented  ·   ·  Flag as inappropriate

        We saw this constantly in our environment with HP ProLiant 360 G7 servers and Broadcom 1GB NICs.

        Disabling VMQ solved loads of our issues.

      • StephenStephen commented  ·   ·  Flag as inappropriate

        I had a lot of network problems with 6 clustered Hyper V Hosts, hosts dropping out of cluster at random times. Since disabling VMQ on all 1GB Broadcom Nics all hosts have been running perfectly. Issue appeared after updating Equalogic firmware on SAN.

      Feedback and Knowledge Base