To improve Windows Server I suggest you ...

Windows 2016 start menu search on GUI should be as comprehensive as Windows 10 and Windows 2012R2

When I hit start and type "Active", for example, the start menu correctly finds "Active Directory Users and Computers", "Active Directory Domains and Trusts", etc. on Windows 10 and Windows 2012R2.
that is NOT the case in Windows 2016 TP5. I have to type in "administrative" to get to "Windows Administrative Tools" and then run my mmc.

I don't know if it is a setting I should enable (maybe Cortana), or I have to wait for some indexing to finish (I've already waited waaay to long; besides Windows 2012R2 does not have this index-wait-time) for this comprehensive search to happen, but now the search function on start menu of Windows 2016 TP5 does not return all the relevant results as it does in other previous versions.

99 votes
Sign in
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

Sass shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Password icon
Signed in as (Sign out)
  • Andreas commented  ·   ·  Flag as inappropriate

    Hi, same **** on 2019 plz fix this! Right after the Update time of 2016 Server thanks!

  • Anonymous commented  ·   ·  Flag as inappropriate

    This is MIKAEL'S SERVICE using Winnt.h header. How ULONG OPERATION_ID; LICENSE#:0105964, KRB03 WK103, DRAWER: 99, Site: 4 Issuer: Hamilton County Office and Representatives. Date: 04/30/2018, exp. date: 05/15/2019.

  • Casey Vanderville commented  ·   ·  Flag as inappropriate

    We are using Server 2016 as an RDS server, and get a lot of users reporting that an application is missing because they searched for it and it didn't come up. Per MS, the search service causes issues on RDS Session hosts and should be disabled. Please find a way to resolve this.

  • Anonymous commented  ·   ·  Flag as inappropriate

    This has been ticking me off lately. It used to work and now doesn't seem to work well. I have ADUC installed on some Admin type boxes. Normally I press Windows and type users and get to Active Directory Users and Computers. On all the 2016 boxes I've setup lately I only see the build in Edit Local Users option. I have to open Server Manager and used the Tools dropdown to get to what I need. Very inconvenient.

  • J Anything commented  ·   ·  Flag as inappropriate

    We're constantly hit by issues with Windows Search on Server 2012. We have a terminal server of around 14 people, and they use search within Outlook all the time. The index will hit around 1.4 million items, and then maybe a week later, it will rebuild itself and take another two days to do so. It really hits the disk hard and actually causes issues with other VM's on the Hyper V host.

    Microsoft have no interest in fixing it, in fact, it's officially not supported in Sever 2016 and will disabled by default, their reason is that it doesn't work properly. Well then fix it MS!

  • Jon Miller commented  ·   ·  Flag as inappropriate

    Windows Search is a steaming pile. I'm not sure this is actually a problem with Windows Search on Windows Server versus Windows 10. I've noticed slight differences across several Windows 10 computers that I have. On some to find "Check for Updates", I have to enter "Updat". Or some other sub-string of the entire word. It varies from one computer to the next. At the moment, I have the problem that for no apparent reason, when I log into my domain account, I get the dreaded "These results may be incomplete..." and it doesn't find anything. However, if I log into the local Administrator account, it works fine. I tried deleting the user profile and it made no difference. I also tried setting the Registry key that allegedly reinstalls/rebuilds the search database. It made no difference. Windows Search really is a non-deterministic piece of ****. It is one of the worse parts of Windows 10.

  • Tijl Deneut commented  ·   ·  Flag as inappropriate

    Hi, I got it working, still unsure what exactly causes it:
    - Windows Search Feature is not installed by default (I installed it)
    - Windows Search services is disabled by default (I've set it to auto start)
    - Cortana (yes :s) does NOT work with the built-in administrator. If I create a new admin user, that is not the built-in administrator, everything now works!

  • Robert Gijsen commented  ·   ·  Flag as inappropriate

    Same cr@p here. Unbelievable that MS didn't spot this or is too arrogant(?) to fix this. This has been an issue ever since the TP's and makes it impossible for most of us to deploy RDS with this. But even my management server gives me alot of headackes in order to find stuff that is actually installed. This is miles back from were we came from. Please fix!

  • Matthew Cronk commented  ·   ·  Flag as inappropriate

    This makes me want to quit IT... It's hard enough that you feel you need to change the names of everything for no apparent reason but you might as well have removed search because it is useless. Please fix this!!!

  • Tom Wardrop commented  ·   ·  Flag as inappropriate

    Yeah this is like the most basic of functions. Windows 10 is plagued with start menu woes (one of the reasons I can't run it at work), and it seems Windows Server 2016 has similar issues.

  • Justin Emlay commented  ·   ·  Flag as inappropriate

    Server 2016 RTM

    The Start Menu is broken in a few ways. For many people newly added programs cannot be searched for. Not until they blow out the local user profile and add it back. The newly generated Start Menu will then have all proper applications that can be searched. In the case of an AD machine, this of course cannot be done (domain admin). However, if you login with a different user you'll find that new user can search for "Active" just fine (after applications/roles have been installed). In the case of all our other machines we have blown out the domain users, added them back and they can search fine. With the exception of...

    The other way I've found the Start Menu to be broken is the local admin user can search for Control Panel items just fine. However, any other logged in user cannot search for any Control Panel items. For example, Update..., Index..., Programs...(for add/remove). Turning on Windows Search doesn't help either.

  • VK commented  ·   ·  Flag as inappropriate

    I can confirm that this was much better in Windows Server 2012 R2! You can for example just type in "programs" in the start menu and you can select between different things like "default programs" , "programs and features", "add or remove programs",... This would be great to have in Windows Server 2016!!!

  • RM commented  ·   ·  Flag as inappropriate

    This is the One Big Dealbreaker that has me continuing to install Classic Shell on my Win10/Server 2016 boxen.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Whatever I want to do on my Windows 7 or Windows 2008, I just type it in the search area and it's i there and it is really great.
    Windows 2016 search is missing the Control Panel items. It took me ages to find the actual "Device Manager" control panel.

Feedback and Knowledge Base