To improve Windows Server I suggest you ...

Lower the priority of "automatic maintenance" (tiworker.exe)

Every now and then after a server restart, tiworker.exe jumps to 100% CPU usage for a long time, effectively DOS-ing single-processor servers.

Google (or bing) for `"automatic maintenance" tiworker.exe` for lots of reports on this issue, including blog posts of people recommending to disable this task.

My suggestion would be to lower that task's priority by default ("below normal" works well based on my tests): 30 minutes of background maintenance and a responsive server is *much* better than 15 minutes of background maintenance and a server which is practically unusable during that time.

3 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Heinrich Moser shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    Yes - having tiworker jump to 100% and render my computer useless is the number one cause of loss of productivity in my day aside from reddit.

Feedback and Knowledge Base