How can we improve the management tools and experience in Windows Server?

Unable to use Remote Desktop

When I used the remote desktop function in Windows admin center, I was always in the loading state and did not response. Whether Chreme or Edge's browser console displays:

PUT https://localhost/api/nodes/192.168.43.4/features/powershell Api/pssessions/instantSession 400

Msft. sme. remote - desktop -- appErrorHandler -- Ajax error 400

Google Chrome 70.0.3538.110

Microsoft Edge 44.17763.1.0

The remote desktop software can be connected normally.

Windows admin center installed in Win10

The server is Windows Server 2019 Core

8 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    赖俊成 shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Geoffrey commented  ·   ·  Flag as inappropriate

        FYI, I am running Server 2016. It's possible that the location of "$RdpGroupPolicyRegistryKey" is different for different versions, one can simply examine the payload of the failed request (the one that Jan mentions) to find the script that's run on the server. It has Get-RemoteDesktopSettings.ps1 at the beginning, and the failure is in the functions Get-RdpNlaGroupPolicySettings and Get-RdpGroupPolicySettings.

      • Geoffrey commented  ·   ·  Flag as inappropriate

        I have a workaround that I found solved this issue. The problem is that the server attempts to run the command
        "Get-Member -InputObject $registryKey "
        when $registryKey is null. This is because
        "$registryKey = Get-ItemProperty -Path $RdpGroupPolicyRegistryKey -ErrorAction SilentlyContinue"
        and the $RdpGroupPolicyRegistryKey has no entries (I'm guessing if the group policy isn't set)

        To work around this, just put any dummy key into the location of $RdpGroupPolicyRegistryKey, which is probably "HKLM:\\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services", which causes the Get-ItemProperty command to not return null.

        After doing this, I had no trouble with the in-browser remote desktop.

      • Jan commented  ·   ·  Flag as inappropriate

        i forgot to say it happens on every browser: ff, chrome and edge

      Feedback and Knowledge Base