PowerShell

The PowerShell forum accepts bug reports as well as feedback and suggestions. For more information, check out the PowerShell Homepage

The following is a list of the states we use to track items.

status meaning
survey We saw this and we are considering it. Please upvote if it’s important to you.
needs more information We don’t understand the issue and need additional details.
investigating We are looking at this internally to understand things like: scenario, reproduction of issue, costing, or other technical details.
in queue The issue is understood and in our unprioritized backlog. Your votes will be used to drive prioritization of this work.
  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. KB3000850

    KB3000850 is not part of the Azure SQL 2014 image, and takes over an hour to install (often timing out) before DSC Extension can run. When update fails to install, causes DSC to fail as well. Easy to reproduce - configure VM image based on SQL 2014 and install DSC using templates.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Desired State Configuration (DSC)  ·  Flag idea as inappropriate…  ·  Admin →
  2. Test-DscConfiguration fails once running against remote machine

    Having the following script:

    configuration SimpleConfig2
    {

    Import-DscResource –ModuleName 'PSDesiredStateConfiguration'
    
    

    node $remoteCommputer
    {
    Environment TestVersion
    {
    Ensure = "Present" # You can also set Ensure to "Absent"
    Name = "TestEnvironmentVariable"
    Value = "TestValue2"
    }
    }

    }

    SimpleConfig2

    Start-DSCConfiguration -Path "SimpleConfig2" -Force -Wait -ComputerName $remoteCommputer -Credential $g_AutomationDefaultVMAccounCred -verbose

    $result = Test-DscConfiguration -Path "SimpleConfig2" -ComputerName $remoteCommputer -Credential $g_AutomationDefaultVMAccounCred

    The config is applied correctly, yet Test-DscConfiguration fails with the following message:

    The configurationData parameter is reserved for future use. The current configuration is used by default.

    + CategoryInfo          : InvalidArgument: (root/Microsoft/...gurationManager:String) [], CimException
    
    + FullyQualifiedErrorId : MI RESULT 4
    + PSComputerName : target-machine
    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Desired State Configuration (DSC)  ·  Flag idea as inappropriate…  ·  Admin →
    investigating  ·  Mark Gray responded

    Anton,

    I am not able to reproduce your issue. What PS / WMF version are you running into this on? Also what OSes are running on the local and remote machines?

    MarkG

  3. If module version is not specified, composite configurations fail to load

    BUG
    Version occurs in: WMF5 Production Preview
    Previous versions? No.

    In a composite configuration scenario, if one of the composite resources contains an import-dscresource statement, and multiple versions of the module are available, the resource fails to load unless a moduleversion is specified.

    The resource works fine if there is only one version available on the machine in question, or a minimum version is specified.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Desired State Configuration (DSC)  ·  Flag idea as inappropriate…  ·  Admin →
    investigating  ·  Mark Gray responded

    Justin,

    This behavior is common to all DSC resources, if I understand your issue correctly. If there are multiple versions of a module installed on your authoring system, you must specify the version that you intend to use in your configuration.

    What behavior are you expecting?

    MarkG

  4. BUG : WMF5 RTM Pull Server HTTPS

    I have setup new DSC Pull Server HTTPS with WMF 5 RTM on Windows server 2012 r2 .

    Any client with WMF 5 RTM installed is able to pull configuration from Pull Server without certificate installed on the machine .

    Even if AllowUnsecureConnection is set to $false in LCM .

    I have tested that on WMF 4.0 machines and I'm getting error if the certificate is not presented .

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Desired State Configuration (DSC)  ·  Flag idea as inappropriate…  ·  Admin →
    investigating  ·  Mark Gray responded

    Mariusz,

    Thanks for the feedback!

    We are attempting to investigate this issue but need more details from you in order to make progress.

    Is the issue that you are running into as follows:
    - WMF 5. based DSC Pull Server configured with HTTPS and server certificate installed properly. I assume this is not a certificate issued by a trusted authority, correct?
    - A WMF 5.0 RTM client does not have the trusted SSL certificate installed in the trusted root folder and the client is able to successfully connect to the Pull Server.
    - A WMF 4.0 client fails to connect when it does not have the trusted root cert installed.

    Please let us know if this is or is not what you are experiencing.

    Thanks, again,

    MarkG

  5. Service DSC resource should not have a default $State

    The Service DSC resource defaults to state = running. It would be great to be able to say "I want to make sure the service is installed, but I don't care what state it's currently in."

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Desired State Configuration (DSC)  ·  Flag idea as inappropriate…  ·  Admin →
    investigating  ·  Mark Gray responded

    Thanks for the feedback!

    We will take this into consideration in a future release.

    MarkG

2 Next →
  • Don't see your idea?

Feedback and Knowledge Base