Please feel free to provide feedback or file bugs here.

Enable-PSremoting fails when loopback address is missing

Votes from Connect: 13

Original Date Submitted: 1/10/2012 7:54:16 AM


********Contact Information********
Handle: Doug Finke
Site Name: PowerShell
Feedback ID: 717747

Frequency: Always Happens
Regression: Yes, this happens in all previous versions

Problem Description:
Do a "netsh http sh iplisten" and machines are listed, but not the loopback address.

Tried Enable-PSRemoting and got the error below. Once the is added to the IP listener list, this works.

It's something that "winrm quickconfig" should catch.

WinRM already is set up to receive requests on this machine.
Set-WSManQuickConfig : <f:WSManFault xmlns:f="; Code="2150858770" M
achine=""><f:Message>The client cannot connect to the destination specified in the request. Verify that th
e service on the destination is running and is accepting requests. Consult the logs and documentation for the WS-Manage
ment service running on the destination, most commonly IIS or WinRM. If the destination is the WinRM service, run the f
ollowing command on the destination to analyze and configure the WinRM service: "winrm quickconfig". </f:Message></f:WS
At line:50 char:33
+ Set-WSManQuickConfig <<<< -force
+ CategoryInfo : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationException
+ FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand

Product Studio item created by Connect Synchronizer due to creation of feedback ID 717747 (

Repro Steps:
See the description.

Expected Results:
It's something that "winrm quickconfig" should catch when it is run as suggested by the error.

Internal BugId: 3274

1 vote
Sign in
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

AdminJoey Aiello [MSFT] (Program Manager, Windows Server) shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Password icon
Signed in as (Sign out)

Feedback and Knowledge Base