Please feel free to provide feedback or file bugs here.

{ not working in ISE with SL keyboard, probably others as well

Votes from Connect: 19

Original Date Submitted: 10/29/2015 9:31:39 PM

Description:
********Contact Information********
Handle: Jan Bocko Kuhar
Site Name: PowerShell
Feedback ID: 1958298
***************************************

Frequency: PowerShell ISE
Regression: Switch to SL keyboard layout and try to type {, which is set to AltGr + B in this layout.

Problem Description:
{ is set to AltGr + b or Ctrl + Alt + B on SL, HR, ... keyboard layouts, which is set to Debugger in PowerShell ISE. This is really annoying when you use this keyboard layouts as you have to switch to other layouts just for the one character, or for the time you are using ISE.
I would like to see use of different keyboard shortcuts, not Ctrl + Alt / AltGr, by programs, such as ISE, as these are quite heavily used for special characters in keyboard layouts.

Product Studio item created by Connect Synchronizer due to creation of feedback ID 1958298 (http://connect.microsoft.com/PowerShell/feedback/ViewFeedback.aspx?FeedbackID=1958298).

Repro Steps:
Switch to SL keyboard layout and try to type {, which is set to AltGr + B in this layout.

Expected Results:

Internal BugId: 15936

2 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    AdminJoey Aiello [MSFT] (Program Manager, Windows Server) shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base