Please feel free to provide feedback or file bugs here.

BUG: Get-Help Get-Service

In the help file it states that wildcards are not permitted. But it accepts a value with a wildcard on the heads or tails and it also accepts just a wildcard with no other characters.

-Name <String[]>
Specifies the service names of services to be retrieved. Wildcards are permitted. By default, this cmdlet gets all of the services on the computer.

Required? false
Position? 0
Default value None
Accept pipeline input? True (ByPropertyName, ByValue)
Accept wildcard characters? false

3 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Eric Ohlin shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • AdminZachary Alexander (Program Manager, Windows Server) commented  ·   ·  Flag as inappropriate

        Yes, it won't show up through Update-Help until we get https://github.com/PowerShell/PowerShell-Docs/issues/1073 addressed. We are working through issues in PowerShell 6 right now before we flip the switch for downlevel versions.

        Yes, the wildcard issue is pretty widespread. We have a tracking issue here: https://github.com/PowerShell/PowerShell-Docs/issues/1672

      • Ivan Mirchev commented  ·   ·  Flag as inappropriate

        Still valid issue ...It is fixed into Web, but not updating the PowerShell Help!
        Also consider: Get-Process. Parameter Name accept wildcard characters: false - both in PowerShell Help and Web

      • Anwar Mahmood commented  ·   ·  Flag as inappropriate

        Still inaccurate in downloaded help as of 20/03/2017 07:19 UTC in English (UK). Extract below; the narrative says wildcards are permitted, but the details section says "accept wildcard characters? false".

        -Name <String[]>
        Specifies the service names of services to be retrieved. Wildcards are permitted. By default, this cmdlet gets
        all of the services on the computer.

        Required? false
        Position? 0
        Default value None
        Accept pipeline input? True (ByPropertyName, ByValue)
        Accept wildcard characters? false

      • Eric Ohlin commented  ·   ·  Flag as inappropriate

        Ahh it does look like this was fixed online now, and its just not hitting the help files in PS even after update-help

        Thanks for the response!

      Feedback and Knowledge Base