Please feel free to provide feedback or file bugs here.

snippets

PowerShell ISE - Where are the default snippets after Win10 Upgrade?

So I've upgraded to Win10Pro 1803 17134.1, opened my trusty PowerShell ISE, pressed CTRL+J and nothing happens!? Even the Get-ISESnippet is not showing any results. I'm using the default snippets and don't have any custom snippets under my documents / PowerShell folder.

It seems to be related to OneDrive or Windows 10 update as both my Desktop and Laptop have the same problem.

According to JRV the same issue occurs on 1809 builds.

Link: https://social.technet.microsoft.com/Forums/en-US/47ded9fb-0501-4953-92cc-ef55dbf86fbe/powershell-ise-where-are-the-default-snippets-after-win10-upgrade?forum=winserverpowershell

Best Regards,
Glenn

$PSVersionTable

Name Value
---- -----
PSVersion 5.1.17134.1
PSEdition Desktop
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0...}
BuildVersion 10.0.17134.1
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

64 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Glenn Goffin shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    13 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Al commented  ·   ·  Flag as inappropriate

        Does adding comments help get notice? This is happening for me, too. No intellisense, ctrl+j crashes the ise. Preview build seems to fix it.

      • Stereo89 commented  ·   ·  Flag as inappropriate

        You can use the preview version temporarily:

        Install-Module PowerShellISE-preview -Scope CurrentUser

        isep

      • postanote commented  ·   ·  Flag as inappropriate

        Update

        Snippets still work, but hitting the CRTL+J or selecting it form the edit menu does not display the stored snippet list.
        Either approach, just shows a small '.' on the screen, where the list is to be displayed.
        If you know the name of your snippet or part of it, type that part of the name and hit enter, the snippet will populate in the editor.

        I've not tried to post a video here or I would showing this.

        The other option, is to write your onw menu option (using a different hotkey combo) for the Add-Ons section and select from there. Of course that is, first writing the necessary code/function to grab your snippet content to display in the ISE or use GCI on the snippet directory to show the names, then use CRTL+J and at the dot, just type the beginning and hit enter.

        These are just the workarounds I came up with today to deal with this until MS can get a fix.

        BTW, other module add-ons can still fail, depending on what they are. For example the ISEModuleBrowser from the MS PSGallery fails hard / crashes the ISE.

      • postanote commented  ·   ·  Flag as inappropriate

        I have several systems that are on the WinInsider builds, slow, fast, and skip ahead (all on the latest WI builds as of this week) and none of them are having these intelisense/snippet, etc. issues.

        So, this is specific to these 1803/1809 releases as far as my tests have confirmed thus far.

        So, I now have to halt / block all Win10 spring edition upgrades as of me discovering this on install today.

        @JeffWilson, snippets are not gone, you can see that by going to your Windows PowerShell folder and navigating to you Snippets folder, they are just not usable from the CRTL+J or other option. Yet, yep, there are gone if one can't use them as expected. Having to navigate to the folder each time to copy and paste, not really something we should have to do.

        So, as others are saying here. We need a fix and no, switching to VSCode enterprise-wide is not an option.

      • Andreas Mariotti commented  ·   ·  Flag as inappropriate

        I have the same issue after updating my Windows 10 from 1709 to 1803 GA version.

        When I have the focus in the editor windows an press CTRL+J for the snippets nothing happens, and when in press CTRL+J again ISE crashes with an unexpected error.

        And there is a second issue in ISE since updating to 1803. IntelliSense for cmdlet parameters is not working. IntelliSense for the Cmdlet name itself works, but when I enter a - for the first parameter only a little . is shown instead of the IntelliSense context menu with the parameter names. And when I press CTRL+SPACE to force IntelliSense ISE crashes also with an unexpected error.

        After a rollback to Windows 1709 ISE works without issues, after updating again to 1803 the issue was again there. I’m able to reproduce this issue on multiple machines.

        There are some more people on the internet that are complaining about this issue, simply google for “ISE crash 1803” and you get some hits

      Feedback and Knowledge Base