Justin DynamicD

My feedback

  1. 365 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    80 comments  ·  General Feedback » Configuration  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD supported this idea  · 
  2. 57 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  General Feedback » Misc  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD supported this idea  · 
  3. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General Feedback » Configuration  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD shared this idea  · 
  4. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General Feedback » Configuration  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD shared this idea  · 
  5. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General Feedback » Configuration  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD shared this idea  · 
  6. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General Feedback » Configuration  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD shared this idea  · 
  7. 299 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    50 comments  ·  General Feedback » Configuration  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD supported this idea  · 
  8. 13 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  PowerShell » Desired State Configuration (DSC)  ·  Flag idea as inappropriate…  ·  Admin →
    Justin DynamicD supported this idea  · 
  9. 96 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    survey  ·  Mark Gray responded

    Justin,

    We totally understand that a robust Pull server / central management solution is something that is critical to your success with DSC. We have invested quite heavily in Azure Automation DSC (AA DSC) to fill many of these needs. With that said, I would be very interested to understand if the AA DSC solution does not work for you (and other customers) and why? Vote and comment if this is important to you.

    Also interesting feedback on our ‘bad ideas’. Thanks!

    MarkG

    Justin DynamicD supported this idea  · 
  10. 49 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  PowerShell » ISE and tooling  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for the suggestion. Given the number of requests, we cannot field all recommendations, so for now we’ll be monitoring this to see if there is broad support.

    Justin DynamicD supported this idea  · 
  11. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  PowerShell » Desired State Configuration (DSC)  ·  Flag idea as inappropriate…  ·  Admin →
    investigating  ·  Mark Gray responded

    Justin,

    This behavior is common to all DSC resources, if I understand your issue correctly. If there are multiple versions of a module installed on your authoring system, you must specify the version that you intend to use in your configuration.

    What behavior are you expecting?

    MarkG

    Justin DynamicD commented  · 

    I would expect it to default to the latest version, possibly return a warning that multiple versions were detected and that version x.x.x was used.

    Currently, you get no indication that it's even a version issue as the composite resource refuses to load at all so the error you get when trying to compile a mof is that it can't find said composite resource. It's only when you open it in ISE do you see the warning that it's expecting the version to be defined because multiple versions exist.

    This could be a curve ball for anyone making their "first configuration" to have it randomly break the first time they play with "update-module"

Feedback and Knowledge Base